Veröffentlicht am Schreib einen Kommentar

Shapeoko2 jetzt per USB angeschlossen

Wie ich vielleicht hier oder da schon mal erwähnt hatte, hat ein Bekannter von mir, der mir damals die Platine für die Shapeoko 2 zusammen gelötet hat, gleich auch noch einen Bluetooth-Baustein drauf gebaut. Das hat in weiten Teilen auch wirklich wunderbar funktioniert und war die Verbindungsart meiner Wahl über viele Jahre hinweg.

Hin und wieder hatte ich Probleme mit dieser BT Verbindung und dies äusserte sich so, dass Windows zwar anzeigte, dass der PC mit der Fräse verbunden sei, aber in EASEL ich keine Verbindung zur Maschine herstellen konnte. Es hat mich dann immer etwas Zeit gekostet, bis es wieder ging und danach wusste ich auch meist garnicht, was die Lösung des Problems war – es ging dann einfach irgendwann mal wieder.

Nun hat mich neulich diese Verbindung wieder geärgert und darum habe ich mich entschlossen, dass ich die Fräse per USB Kabel anschliessen wollte. Doch mein Window10 PC wollte nach dem Einstecken der Fräse immer irgendwelche Treiber, welche ich ihm nicht unterjubeln konnte. Alles seltsam. Da ich zu dieser Zeit einen recht alten Laptop für die Fräse verwendet habe, der schon recht langsam war und das Display war auch nicht mehr besonders, kam in mir der Gedanke auf, dass ich mit einen neuen Fräs-PC zulegen könnte.
Meine Wahl fiel dann auf einen gebrauchten Mini-PC von Fujitsu, welchen ich für 140 Euro in Ebay ergatterte. i5, 8GB RAM und 128 GB SSD sind davon die Eckdaten. Und eben klein. Circa 20 x 20 x 6 cm und VESA-mountbar. Ich hatte noch einen alten 17″ Flachbildschirm und dort habe ich den PC (mittels VESA) hinten „draufgeschnallt“. Dann noch einen USB-Hub angesteckt und diesen an die Unterseite des Monitors befestigt, damit ich Maus, Tastatur und Fräse leicht anstecken kann.

Als ich dann die Fräse dort das erste Mal in Betrieb per USB nehmen wollte, hat dieser PC auch nicht mehr nach Treiber gefragt, sondern die Shapeoko einfach erkannt und installiert. Die Tage darauf hatte ich aber doch wieder leicht Probleme mit der Verbindung bzw. dessen Aufbau und darum habe ich überlegt, was ich da noch machen könnte. Irgendwann ist mir eingefallen, dass das Bluetooth-Bauteil ja noch auf der Platine war und darum habe ich dieses entfernt (war nur gesteckt).

Und seither klappt der USB-Verbindungsaufbau jedes Mal! Es kann vorkommen, dass wenn ich nicht den gleichen USB-Anschluss am USB-Hub verwende, dass sich die Shapeoko einen anderen COM-Port schnappt, aber dieser ist in EASEL dann auch gleich umgestellt.
Ich kann mir das nur so erklären, dass der Bluetooth-Chip und der USB-Port sich hin und wieder um die COM-Ports gestritten haben und das dieser „Konflikt“ die Ursache für meine Verbindungsprobleme war. Seit ich die kleine Bluetooth-Platine entfernt habe, läuft eigentlich alles sehr, sehr problemfrei und stabil. 😉

Markus Ostermeier
Markus Ostermeier
Contact: markus(at)ostermeier(dot)net - My Coffee is always #000000! - 3CX-Code: A3-K29PNA-4RLNFH-4AQMP-39JJL-J2SDZ-XE9G8-MO73, Code Plus 8FWHPXXF+XQ, GPS Location 48°44'59.9"N 11°58'30.8"E - It all started with a Commodore 64.
Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.