Veröffentlicht am 10 Kommentare

Windows 10 und SMB1 / SMBv1 – Stand: August 2020 bzw. Windows10 Vers. 2004

Vorgeschichte:
Neulich hatte ich das Problem, dass ein relativ aktueller Windows10-Client nicht mehr auf das Netzlaufwerk einen älteren Server zugreifen konnte, auf dem noch (aus sentimentalen Gründen) noch eine alte Anwendung läuft. Auf besagten Server läuft Microsoft Server 2003, was schon mal einen Hinweis gibt, aus welcher Zeit(epoche) die angedeutete Software stammt. 😉

Symptome:
Eigentlich ist das schnell erklärt. Der User klickt auf besagtes Netzlaufwerk, der Windows Explorer fängt an zu „grineln“ und nach 1-2 Minuten kommt eine Fehlermeldung, dass auf das Laufwerk nicht zugegriffen werden kann.

Fehlersuche:
Zuerst dachte ich an „seltsame Zugriffsrechte“. Aber meine Recherche hat keinen Fehler ergeben. Dann hatte ich „Netzwerkproblem“ als Ursache als Idee – was ich aber bald verwerfen konnte, weil die anderen Netzlaufwerke ja alle gingen. Schlussendlich habe ich mal den 2003er-Server rebootet, weil ich den Verdacht hatte, dass sich der vielleicht „aufgehängt“ hatte. Alles ohne Erfolgt.

Lösung:
Dann hatte ich den Einfall, dass ich schon mal ein Problem mit einem Mac hatte, der auf auf eine Freigabe von einem Windows7-PC zugreifen wollten und nicht konnte. Damals lag das Problem beim SMB-Protokoll und das da eine Version „out of Date“ war.
Also hab ich in der Richtung weiter geforscht. Ich bin dann über einen Post von mir gestolpert, in dem ich im September 2019 bereits erklärt habe, wie man SMBv1 unter Windows10 aktiviert:

Aber Windows 10 hat sich weiter entwickelt und der oben beschriebene Weg funktionierte leider nicht mehr. 🙁
Aber ich habe einen neuen Weg gefunden und dieser funktioniert über die PowerShell (Merken: TShirt mit „Powerschäl“ entwerfen!). Es gibt für die PS einen Befehl, mit dem man die SMBv1 Unterstützung wieder aktivieren kann:
(PowerShell als ADMIN ausführen!)

Enable-WindowsOptionalFeature -Online -FeatureName smb1protocol 

Ich bin auf folgenden Seite darauf gekommen:

Nach dem Ausführen des Befehls (als Admin) braucht der PC noch einen Neustart und im Anschluss könnte ich auf das Share des alten 2003er Server wieder zugreifen. So weit, so gut.
Aber es hat natürlich auch einen Grund, warum in den aktuellen Windows10-Versionen SMB1 nicht mehr aktiviert/installiert ist. SMBv1 ist nicht mehr sicher! Aber in manchen Fällen braucht man es halt noch, so wie in meinem Fall.

Es gibt von Microsoft eine sehr schöne Seite, auf der eigentlich alles wissenswerte steht.

Dort sehen auch ein paar interessante Informationen, die ich hier nochmal gesondert hervorheben möchte:

In Windows 10 Fall Creators Update und Windows Server, Version 1709 (RS3) und höheren Versionen, wird das Netzwerkprotokoll Server Message Block Version 1 (SMBv1) nicht mehr standardmäßig installiert.

Quelle: https://docs.microsoft.com/de-de/windows-server/storage/file-server/troubleshoot/smbv1-not-installed-by-default-in-windows

Bedeutet also, dass seit dem Windows 10 Update 1709 (und höher) SMBv1 nicht mehr installiert ist und somit auch nicht mehr funktionieren sollte. Das wäre ja ungefähr im September 2017 gewesen! Warum der PC dann noch solang funktioniert hat, ist mir ein Rätsel.

Microsoft hat das SMBv1-Protokoll in 2014 öffentlich als veraltet eingestuft.

Quelle: https://docs.microsoft.com/de-de/windows-server/storage/file-server/troubleshoot/smbv1-not-installed-by-default-in-windows

Aha. Seit bereits 2014 ist SMB Version 1 ganz offiziell veraltet. Hat aber dann doch noch ein paar Jahre gedauert, bis sie es „abgeknipst“ haben. Und noch so als Site-Fact: Auf einem Windows Server 2012 R1 (W2K12R2) ist SMB noch aktiv und funktioniert.

Windows 10 Home und Windows 10 pro enthalten nach einer Neuinstallation weiterhin standardmäßig den SMBv1-Client. Wenn der SMBv1-Client nicht 15 Tage lang verwendet wird (mit Ausnahme des Computers, der ausgeschaltet wird), wird er automatisch deinstalliert.

Quelle: https://docs.microsoft.com/de-de/windows-server/storage/file-server/troubleshoot/smbv1-not-installed-by-default-in-windows

Auch ein interessanter Vorgehen. Window 10 komplett neu installiert, dann installiert Microsoft den SMBv1 Client per default mit. Wird er denn 15 Tage nicht genutzt, so erfolgt automatisiert dessen Deinstallation. Damit möchte MS wohl verhindert, dass User, die dieses Protokoll noch benötigen vor den Kopf gestossen werden. Aber wohlgemerkt nur bei einer Neuinstallation. Macht man hingegen brav die Windows-Updates, so „verschwindet“ plötzlich die SMBv1 Funktionalität. Es gibt aber einen Lichtblick…

Wenn ein Administrator SMBv1 erneut installiert, werden keine weiteren Versuche unternommen, ihn zu deinstallieren.

Quelle: https://docs.microsoft.com/de-de/windows-server/storage/file-server/troubleshoot/smbv1-not-installed-by-default-in-windows

Würde also bedeutet, wenn ich als Windows-Admin SMBv1 über die Powershell nach installierte, dann dürfte das Windows10 nicht mehr versuchen diesen veralteten SMB-Client zu entfernen. Da bin ich ja mal gespannt. 😉
Aktuell ist es noch zu früh, dass ich darüber eine Aussage treffen kann, da ich erst den Zeitraum von 15 Tagen verstreichen lassen muss. Aber ich habe so das Gefühl, dass es keine 2 Wochen dauert, bis die Netzwerkverbindung zu dem Microsoft Server 2003 wieder nicht mehr geht.

Nachtrag vom 17. August 2020:
Wie in den Kommentaren bereits angedeutet, gibt es bei den Windows-Features den Punkt „Unterstützung für die SMB 1.0/CIFS-Dateifreigabe“ und dort den Unterpunkt „SMB 1.0/CIFS automatisch entfernen“. Es soll angeblich reichen, wenn man diesen Unterpunkt abhakt und die SMB1-Verbindung soll damit dauerhaft funktionieren. Leider war dies bei meinem Test nicht der Fall. ;-(

Veröffentlicht am Schreib einen Kommentar

Windows Fenstermanagement mal anders

Heute hatte ich mal den Fall, dass ich bei einer Remote-Desktopverbindung kurzzeitig auf den Betrieb mit zwei Bildschirmen umgestellt hatte, dort (auf dem zusätzlichen Bildschirm) dann Fenster positioniert hatte und dann doch wieder zurück umgestellt habe auf den Betrieb mit nur einem Bildschirm.

Jetzt ergab sich darauf das Problem, dass der Server sich aber merkte, dass manche Programmfenster ursprünglich auf dem „anderen Bildschirm“ waren und diese dort (wenn auch nicht mehr vorhanden) platziert hat. Somit waren diese Fenster ausserhalb der Reichweite des Benutzers, obwohl diese in der Taskleiste sichtbar waren.

Um die Fenster wieder auf den „Hauptbildschirm“ zu bekommen, gib es von Windows „Bordmittel“ bzw. einen Shortcut, den ich bislang nicht kannte und ziemlich verblüfft war. Nachstehen eine kurze Anleitung, wie ihr das „verschwundene Fenster“ wieder zurecht rückt.

Wählt als erstes mittels „ALT + Tab“ das Programm aus (es muss dafür bereits gestartet worden sein) und lasst dann die Tasten wieder los.
Nun drückt „ALT + Leertaste + V“ und es erscheint am Bildschirm ein „Pfeilsymbol“. Nun könnt ihr mit den Cursor-Tasten das aktive Fenster wieder frei verschieben. Wenn ihr noch wisst, wo vorher der zweite Bildschirm positioniert war, dann könnt ihr jetzt sehr einfach in die entgegengesetzte Richtung das Fenster zurück ins Hauptfenster verschieben. 

Veröffentlicht am Schreib einen Kommentar

Kurzfassung: VERTRAUENSSTELLUNG ZWISCHEN ARBEITSSTATION PRIMÄREN DOMÄNE KONNTE NICHT HERGESTELLT

Kurzfassung:

… So, ab jetzt ist es leicht. Man kann sich nun wieder als lokaler Admin anmelden, den PC „sauber“ aus der Domäne entfernen und in einen Arbeitsgruppe packen. Dann einen Neustart durchführen und den PC wieder der Domäne hinzufügen. Nach ein Reboot und dann sollte alles wieder gut sein. :-)

Den vollständigen, ursprünglichen Post findet ihr hier:

Veröffentlicht am Schreib einen Kommentar

Windows Vista: Ausschalt-Button wieder einstellen

Am vergangenen Wochenende „durfte“ ich mal wieder einen PC einer Bekannten neu installieren. Eigentlich keine große Sache, aber der Rechner stammte aus der „Windows-Vista-Ära“ und brachte damit alle Eigenheiten dieses Betriebssystems mit. Mal davon abgesehen, dass es gefühlt 1000 Updates nach der Grundinstallation gab, regte mich an Vista vorallem auf, dass der „Ausschalt-Button“ nicht mehr den PC runter fuhr, sondern ihn in den Standby schicken sollte. Irgendwas hat an dem PC nicht gestimmt, denn dieser wollte nicht in den Standby, sondern machte nur den Bildschirm dunkel und die internen Lüfter lüfteten lustig weiter. Also Grund genug, um den Ausschalt-Button umzukonfigurieren und ihn wieder so einzustellen, dass er per default den PC herunterfährt und im Anschluss ausschaltet.
Nachfolgend noch eine kleine Anleitung, wie man hierzu vorgeht:

  • man geht in die Systemsteuerung > Engergieoptionen
  • den aktuell ausgewählten Energiesparplan suchen und auf “Energiesparplaneinstellungen ändern” klicken
  • dann unter “Erweiterte Energieeinstellungen ändern” den Netzschalter/Laptopdeckel
  • den Eintrag von „Energie sparen“ auf „Herunterfahren“ ändern
Veröffentlicht am Schreib einen Kommentar

System-Infos unter Windows mit einem Tastendruck aufrufen

WindowslogoNun bin ich auch schon länger auf Windows unterwegs, aber heute habe ich in einem Forum einen wirklich guten Tipp gelesen.
Es kommt ja ziemlich oft vor, dass man die grundlegenden Infos von einem System brauch und da bin ich in der Vergangenheit immer über das „Start-Menü“ – „Computer“ und anschließend auf „Systemeigenschaften“ gegangen. Dieses Fenster kann man aber auch mit nur einen Tastendruck/-kombination aufrufen.
Dazu hält man einfach die Windows-Taste gedrückt und betätigt zusätzlich die Pause-Taste. 😉

Veröffentlicht am Schreib einen Kommentar

Spybot 2.x Anleitung

Bildschirmfoto 2013-01-08 um 11.42.09Heute hab ich seit längerem wieder mal „Spybot – Search & Destroy“ verwendet und dabei ist mir aufgefallen, dass es die Software nun in der Version 2.x gibt. Mein letzter Stand war die Version 1.6.2 … da hat sich anscheinend einiges getan.
Des weiteren ist mir aufgefallen, dass es nun auch kostenpflichtige Fassungen des Programms gibt. Aber auch immer noch eine Free-Version, die für den privaten Einsatz taugt.
Die Software kann nach wie vor unter der URL www.safer-networking.org runter geladen werden.

Vom optischen her hat sich einiges in der neusten Version getan, so dass ich auch mit meinen (Installations- und Bedienungs-) Erfahrungen nicht weiter kam und mir erst mal die Software selber anschauen musste. Ich hab festgestellt, dass sich vieles vereinfacht hat, wenn man nicht umstellt. Es gibt aber auch noch die Möglichkeit Spybot in so einer Art „Expertenmodus“ zu installieren und da hat man dann bestimmt mehr Möglichkeiten, was die Desinfektion des System angeht. Das habe ich aber heute nicht getestet und so konzentrieren wir uns auf die Standard-Installation. Da ich einen Bekannten die Bedienung erklären sollte, da er die Software auf seinen PC ausführen muss, hab ich eine Download-, Installations- und Bedienungs-Anleitung verfasst, die leicht verständlich sein sollte – weil ohne viel Wort und dafür mehr Bilder 😉

Die Anleitung für Spybot 2.x findet ihr HIER.
HINWEIS: Auf der Seite 8 im PDF ist mir ein Pfeil verrutscht. Im obersten Bild mit man auf „Datei-Scan“ klicken, damit die Suche beginnt.

Veröffentlicht am Schreib einen Kommentar

Kein Zwangs-Neustart nach Windows-Updates

Ok, ich weiß, Windows XP ist nicht mehr ganz Stand der Dinge, aber ich selber habe noch einen PC mit diesem Betriebssystem. Und den PC lass ich auch weiterlaufen, solange bis er das Zeitliche segnet. Hab heute Einladungskarten gestaltet und ausgedruckt und dafür sollte der Rechner einige Stunden durchlaufen. Nun hatte ich aber das Problem, dass es neue Windows-Updates gab und diese auch automatisch installiert wurden. Daraufhin wollte der PC sich aber immer automatisch neu starten. So im Intervall von 10-15 Minuten kam die Meldung, ob der Rechner selbstständig einen Reboot durchführen dürfe. Auf diese Meldung musste ich warten und auch „Später neustarten“ klicken. Damit mir dies in Zukunft nicht mehr passiert, kann man die Zeit bis zu einem automatischen Neustart in dem Gruppenrichtlinien-Editor einstellen. Und zwar so:

  • Start / Ausführen (oder <Win>-<R>), gpedit.msc eingeben und mit <Enter> bestätigen
  • In der linken Navigation zu folgendem Verzeichnis navigieren: Richtlinien für Lokaler Computer > Computerconfiguration > Administrative Vorlagen > Windows-Komponenten > Windows Update
  • Erneut zu einem Neustart für geplante Installationen auffordern” doppelklicken
  • Die Standard-Einstellung von Windows XP ist “Nicht konfiguriert”, hier kann man nun z.B. folgendes einstellen, damit die Meldung anstatt alle 10 Minuten nur noch alle 5 Stunden erscheint:
Veröffentlicht am 2 Kommentare

Windows Product Key stimmt nicht und muss geändert werden.

Es kommt immer wieder vor, dass der Product Key bei Windows (XP, Vista oder 7) nach der Neuinstallation nicht stimmt oder vielleicht schon vor eingetragen ist (Stichwort: OEM Install CDs).
Auf der Webseite support.microsoft.com/CK gibt es ein Tool, mit dem man sehr einfach und komfortabel diesen Key ändern kann.

Veröffentlicht am Ein Kommentar

PC Inspector File Rescue

Letztes Wochenende sollte bei einem Bekannten dessen PC mit Windows XP neu installieren. Als braver IT’ler hab ich vorher einen Datensicherung auf einen USB Stick gemacht. als dies erledigt war, ginge ans Windows Setup von CD. Als ich dann zwei Partitionen mit Fat32 angezeigt bekommen habe, stimmte ich mich mit meinem Bekannten ab, dass ihm zukünftig auch eine Partition reichen würde und wir die zwei bestehenden löschen könnten. Gesagt, getan.
Aber, oh Schreck, die zweite Festplatten Partionen war der noch steckende USB Stick mit der Datensicherung drauf!
Ok, was nun tun? Da ich den Stick glücklicherweise noch nicht formatiert hatte, was somit nur die Spur Null gelöscht, bzw der Master Boot Record mit den Filesystem-Informationen. Somit müssten die eigentlichen Daten noch vorhanden sein. Also erst mal keine Panik.

…nach etwas rumprobieren musste ich feststellen, dass das Wiederherstellen des MBR nicht so ohne weiteres möglich ist und einen Boot von der Windows CD erfordert. Darauf hatte ich aber irgendwie keine Lust 😉

Also machte ich nicht auf die Suche noch einem kostenlosen, downloadbaren Datenrettungsprogramm und wurde ziemlich schnell fündig. „PC Inspector File Recovery“ hiess das gute Stück und um es vorweg zu nehmen, damit konnte ich die noch auf dem USB Stick vorhanden Daten kopieren.

Nur der Weg dahin war, nun ja sagen wir mal, etwas holprig.
Ich hatte zwei Rechner zur Verfügung. Einem den PC, auf den ich gerade Windows neu installiert hatte, dort aber noch keine Hardwaretreiber installiert waren. Und dann noch mein MacBook Pro. Da ich am PC weiter installieren wollte versuche ich es zuerst auf dem Mac in einem Windows 7, welches in VMware Fusion läuft. Das Programm ließ sich installieren, starten, fand die Daten auf dem USb Stick und fing auch an diese zu recovern. Allerdings brach er mir während der Rücksicherung immer wieder ab und das Programm fror ein. Ich dachte mir, es Länge an der virtuellen Maschine und dass dadurch die Datensicherung nicht gescheit laufen würde.
Ich hatte noch ein Windows 7 mit dabei, welche dann mittels Boot Camp auf dem MacBook installiert war. Also hab ich diese gestartet und auch dort den PC Inspector installiert. Da war es dann ganz komisch. Das Programm ließ sich wieder installieren, lief auch, fand den Stick, aber nicht die Daten darauf. Auch nich diversen Versuchen konnte ich keine Daten rücksichern.
Die Schlussendliche Lösung war dann, dass ich mittlerweile soviel Zeit vertan hatte, dass der PC mit dem neue. Windows XP auch mit allen Treibern versorgt war und ich dort noch eine. Versuch Wagen wollte. Und siehe da, dort lief alles wunderbar. Der USB Stick wurde tadellos erkannt, auch die alte, gelöschte Partition wurde erkannt und ich konnte die Daten von dort wegkopieren. All dies funktionierte, wie man es sich eigentlich vorstellen würde.
Vielleicht noch ein Tipp/Empfehlung am Rand. Ich bilde mir ein, dass eine Rücksicherung der kompletten Ordnerstruktur nicht so gut funktioniert hat, wie dann zum Schluss dass Kopieren der einzelnen Ordner. Aber dass kann auch nur mein subjektiver Eindruck sein.

Vielleicht helfen diese Zeilen ja irgendwann jemanden, der sich in eine ähnlich ungeschickte Situation manövriert hat, wie ich damals. 😉