Internet-Logbuch vom 30. Januar 2018

AutoStart Ordner unter Windows 10/8.x aufrufen

Die "Älteren" unter uns kennen noch das Autostart-Menü in der Windows Start-Leiste. Diese hat man in regelmässigen Abständen auch gerne mal ausgemistet, weil irgendwelche Programm dort Einträge vorgenommen haben, die den Rechnerstart verlangsamt haben. 

Seit Windows 8.x und 10 "gibt" es diesen Ordner nicht mehr… zumindest ist dieser nicht mehr so einfach zu finden. Dennoch gibt es einen recht einfachen Weg, um die dortigen Einträge zu sichten.

Dazu einfach mittels Windows-R den "Ausführen-Dialog" öffnen und dort in die Befehlszeile shell:startup eintragen.

Anschliessend öffnet sich ein Fenster, in dem ihr alle Einträge des AutoStart seht. Dort könnt ihr zum Beispiel Programme bzw. deren Verknüpfungen hinzufügen und somit starten diese auch beim nächsten Rechnerstart. Ebenso könnt ihr von dort Einträge einfach raus löschen.

Zur Vollständigkeit hier auch noch der Pfad auf dem Datenträger, wie er ungefähr bei euch (unter Windows 10) aussehen könnte:
("USER" müsst ihr dann mit dem Windows-Benutzernamen ersetzen)

C:\Users\USER\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Startup

macOS: DNS Cache löschen (DNS Flush)

Mit dem Webseitenumzug zu einem neuen Provider kommen auch Änderungen im DNS daher. 
Ich wollte dann immer wieder mal schauen, ob sich die neuen DNS Einträge schon aktualisiert haben und musste dazu den lokalen DNS Cache löschen. 

Geht auf deinem Windows-PC relativ einfach und war mir auch bekannt. Einfach die "Eingabeaufforderung" als Administrator starten und dann den Befehl "ipconfig /dnsflush" ausführen.

An meinem iMac unter macOS war mir der Befehl nicht so geläufig und ich musste diesen erstmal googlen. Aber ich wurde sehr schnell fündig und wollte euch diesen hiermit mitteilen.

sudo dscacheutil -flushcache; sudo killall -HUP mDNSResponder

amplicom Ringflash 100 / Telefonanrufverstärker mit Blitz und lautem Ton

Und hier noch der Hinweis auf ein Gerät, welches gerade für ältere Menschen und in Umgebungen, in denen es sehr laut ist, interessant sein kann.

Der "amplicom Ringflash 100" ist ein kleiner Würfel, der in die bestehende analoge Telefonleitung gesteckt wird und dann bei einem Anruf blitzt und ein lautes Signal von sich gibt. Ca. 95 dB!

Ihr bekommt den Telefonverstärker bei Amazon* für ca. 25,00 EUR. Es gibt auch noch ein Modell, welches die Bezeichnung "200" trägt und ca. das doppelte kostet, aber mir erschloss sich nicht, in was sich die beiden Geräte unterscheiden. Hmm?!

* Wenn Ihr etwas über einen Partner-Link kauft, erhalte ich von Amazon ein paar Cent Provision für die Empfehlung. Für Euch ändert sich dadurch am Verkaufspreis nichts. (Amazon-Affiliate-Link des Amazon Partner Programm)

distybox 300: Schnurlose TAE für DECT

Eine sehr interessant Box, für die ich zwar momentan noch keinen Einsatzfall habe, aber vielleicht dann sehr hilfreich sein kann.
Mit der distybox 300 kann man ein kabelgebundenes Gerät (Telefon, Fax usw.) mittels Dect an eine Basisstation anbinden. Das kann sehr praktisch sein, wenn an dem Standort kein Telefonkabel vorhanden ist und man auch keines verlegen möchte bzw. kann. 
Das Teil kostet bei Amazon* ca. 82,00 EUR und ist, wenn man so eine Lösung sucht, sicher eine Überlegung wert.
Vielleicht noch kurz zur Erklärung, wenn jemand den Begriff nicht kennt:

Dieses Bild veranschaulicht nochmals recht schön und einfach, wie die Box funktioniert und wie sie angeschlossen werden soll. Quelle: conrad.com

* Wenn Ihr etwas über einen Partner-Link kauft, erhalte ich von Amazon ein paar Cent Provision für die Empfehlung. Für Euch ändert sich dadurch am Verkaufspreis nichts. (Amazon-Affiliate-Link des Amazon Partner Programm)

Apple AirPods: Problem beim Verbinden

Hier nur kurz notiert. Ich habe nun seid geraumer Zeit die Apple AirPods und als ich mir diese gekauft habe, war eher die Neugierde im Vordergrund, als die Gewissheit die Dinger zu brauchen.
Allerdings musste ich recht bald feststellen, dass dieses Zubehör äusserst praktisch ist und sich komplett in meinen Alltag integriert hat. Das liegt aber auch zum größten Teil daran, dass das Pairing im Normalfall dermassen reibungslos funktioniert, dass man nicht darüber nachdenken braucht.

Aber nun genug des Vorgeplänkels, jetzt zu meinem Problem, welches ich neulich hatte. Normalerweise verbinden sich die AirPods automatisch kurz nach der Herausnehmen aus dem Ladecase mit dem iPhone. Doch dieses mal hatte ich am linken Kopfhörer kein Audio-Signal und auch am iPhone tauchte dieser AirPod in der Akku-Anzeige nicht auf.
Ich dachte mir nichts weiter und habe die beiden AirPods wieder in der Case gesteckt und kurze Zeit drauf wieder entnommen, mit dem gleichen Phänomen. Da ich gerade unterwegs war und auch nicht viel Zeit hatte, beließ ich es bei der einseitigen Audio-Wiedergabe, was zwar nicht schön war, aber auch nicht weiter tragisch.

Als ich dann wieder zuhause war, nahm ich mich des Problems wieder an und auch hier klappte die Verbindung wieder nicht.
Erst als ich die Apple-Support-Webseite zu Rate zog, konnte ich dass Problem lösen. Um es vorweg zu nehmen, es hat nichts geholfen, dass ich mit einem (kurzen) Druck auf den Sync-Taster auf der Rückseite die AirPods neu mit dem iPhone verbinden ließ. 
Erst als ich diesen Taster für 15 Sekunden gedrückt hielt und dann die Verbindung wieder neu aufbaute, ging der linke AirPod auch wieder. 
Ich war dann sehr happy, weil ich schon befürchtet hatte, dass dieser Ohrstöpsel vielleicht kaputt gegangen wäre, doch so wie es scheint, hatte sich nur irgendwie die Software verschluckt und musste die Verbindung einfach komplette neu initialisieren.

Gutenberg und WordPress

Neulich habe ich mehr zufällig was von "Gutenberg" und WordPress mitbekommen und bin da etwas stutzig geworden.
Kurz zur Erklärung:
"Gutenberg" ist der Projektname für den neuen WYSIYG Editor, der (soweit ich das verstanden habe) mit dem Major-Release von WordPress 5.0 kommen soll.

Ich hab dann auch erfahren, dass es bereits jetzt schon diesen Editor, der sich noch in starker Entwicklung befindet, als Plugin zu haben gibt. 
Ich habe mit darauf hin dieses Plugin geholt und installiert und nun einige Artikel (auch diesen hier) damit verfasst.

Wie ihr hier sehr schön erkennen könnt, ist "Gutenberg" sehr schlicht beim Schreiben aufgebaut. Nötige Element z.B. zum Formatieren eines Textes oder zum Einfügen eines Links, blenden sich ein, wenn ihr ein Textstück markiert – kennen wir von den aktuellen Microsoft-Office-Versionen.

Ich muss sagen, dass mir das Schreiben mit dem neuen Editor recht viel Freude bereitet, da dieser optisch sehr dezent und unaufdringlich daher kommt. Nach wie vor sind alle Funktion vorhanden, blenden sich aber ggfs. ein.  
Die "Eigenschaften-Leiste" am rechten Bildschirmrand kann man auch ausblenden und dann erinnert das Schreiben in "Gutenberg" eher an das Arbeiten wie in "Byword" am Mac oder ähnlichen Apps. Alles sehr clean und aufgeräumt. Ich denke, dass ist so ein Trend, dann man bereits seit einiger Zeit bei Editoren für Blogger erkennen kann. 

Neu sind unter anderem auch "Blocks" und dabei sind Elemente gemeint, die in einem Artikel vorkommen können. Also Text- und Bild-Elemente sind da wohl die prominentesten Vertreter, aber es gibt auch noch eine ganze Reiher anderer Blocks, die man in einem Post einbauen kann.

Was auch mit "Gutenberg" einfach geworden sein soll, ich aber noch nicht ausprobiert habe, ist das Anlegen und Schreiben von mehrspaltigen Texten.

Alles in Allem gefällt mir der neue Editor wirklich gut und wenn man bedenkt, dass sich Gutenberg eigentlich noch in der "Beta" und somit in der Entwicklung befindet, dann muss ich sagen, dass sich das Projekt schon auf einem sehr guten und brauchbaren Stand befindet. 
Ich bin aber auch gespannt, wie sich dieser Editor im Laufe der nächsten Monate und bis zur Veröffentlichung von WordPress 5.x weiter entwickeln wird.

Artikelbild bei den einzelnen Artikel ausblenden (WordPress Theme Twenty Seventeen)

Nachdem ich nun bei einem neuen Webhosting-Provider bin (allinkl.com), dachte ich mir, es wäre auch mal an der Zeit ein neues Theme für meinen Blog auszuprobieren. 
Ich wollte etwas, was sehr schlicht und klar ist und nicht zu verspielt. Nachdem ich einige Themes mit angeschaut und ausprobiert hatte, bin ich bei "Twenty Seventeen" hängen geblieben. Das Theme ist direkt von WordPress selbst und (Stand heute) das aktuellste.

Allerdings hatte ich mit dem Theme ein Problem, da es mit bei einzelnen Artikelseiten das Artikelbild doppelt anzeigte. An dem Problem bin ich bin zu einem gewissen Grad selber schuld, da bei meinem alten Theme (Nano von Yoothemes.com) das Artikelbild nicht per Default auf der Artikelseite angezeigt wurde. Aus diesem Grund hab ich dann das selbe Bild nochmals zu Beginn des Textes eingebaut. 
Mein aktuelles Theme verhält sich da etwas anders und somit wird das Artikelbild dort nun doppelt angezeigt.

Das hat mir überhaupt nicht gefallen und ich begab mit auf die Suche nach einer Lösung für dieses Problem. Es dauerte auch nicht lange und ich wurde auf einer englischsprachigen Webseite fündig.
Und wie es sehr oft bei solchen Problemen ist, reichen ein paar einfache Zeilen Code um es zu lösen.

Hierzu noch die Anmerkung, dass ihr den Code unbedingt über das WordPress-Backend einbaut und NICHT(!) an den original CSS Dateien rumfuhrwerkt, da diese bei einem Theme-Update dann auch wieder überschrieben werden. 
Im Backend könnt ihr dies sehr elegant über "Design" und dann "CSS bearbeiten" bewerkstelligen.

Fügt dort einfach nachstehenden Code ein:

.single-featured-image-header {
display: none;
}

Wie ihr seht – auch gleich in der Live-Ansicht – wird so das "obere" Artikelbild sofort ausgeblendet.

Telekom Smart Router ist nicht mit den AVM Repeater kompatibel

Neulich habe ich bei einem Bekannten dessen DSL Anschluss umgestellt und er hat von der Telekom einen sogenannten "Smart Router" erhalten.

Wer von euch das Gerät nicht kennt, dem sei diese Produktseite empfohlen
https://www.telekom.de/zuhause/geraete-und-zubehoer/wlan-und-router/speedport-smart?wtmc=sbzf1127044fn-bra-285940760-21375374480-232180032653

Nun hat aber mein Bekannt ein relativ großes Haus und so stellte sich einige Tage später heraus, dass der DECT Empfang nicht an allen Stellen des Gebäudes gewährleistet ist.
Ich hab empfohlen, dass sich mein Bekannter einen dieser AVM Dect Repeater besorgt und ich habe noch kurz in die Artikelbeschreibung geschaut und dort stand "Kompatibel zu DECT-Basisstationen anderer Hersteller". 
Also habe ich ihm das Modell "AVM Dect Repeater 100" empfohlen, welches er dann auch bestellt hat. Einige Tage später rief er mich an und meine die Lieferung sei bei ihm eingetroffen und ich solle den Verstärker installieren.

Aber irgendwie gelang es mir vor Ort nicht, dass der Telekom Smart Router den Repeater , der sich im "Pairing Modus" befand, fand.
Somit musste ich mal im Internet recherchieren und dabei stellte sich tatsächlich heraus, dass diese AVM Verstärker nicht mit den Telekom-Routern kompatibel sind. Es hat irgendwas mit der Verschlüsselung zu tun, aber ganz genau habe ich mich da jetzt auch nicht eingelesen.

Nachdem ich das nun wusste, haben wir den AVM Repeater wieder eingepackt und mein Bekannter schickte diesen zurück.
Nun machten wir uns auf die Suche, ob es nicht andere Dect Repeater gäbe, die mit eben diesen Telekom Smart Router zusammenarbeiten können. Wir sind auch fündig geworden, doch leider sind diese Geräte etwas teurer.

Was uns noch am besten gefallen hat, waren die Geräte von WanTec. Diese müssten laut Produktbeschreibung auch zu den Smart Router kompatibel sein.

SAT Mode : kompatibel zu T-COM Speedport, Fritzbox, Swisscom Internet Box, TP-Link, ,….

Ok, ich hab gerade selber bemerkt, dass sie nicht explizit den Smart-Router der Telekom erwähnen.

Preislich liegt das Gerät bei Amazon zwischen 100 und 130 EUR und derzeit haben wir noch keines davon bestellt, weil wir erst mal die Position des Smart Routers verändert haben und uns davon erhoffen, dass vielleicht die Abstrahlung jetzt besser ist und somit ins letzte Eck im Haus reicht. Damit sind wir jetzt momentan am testen und vielleicht können wir uns die Investition auch sparen.

formschönes Design ohne zusätzliches Steckernetzteil, kabellos

Nett finde ich auch diese Zeile in der Produktbeschreibung. Man hätte das Design aber auch als "lieblos" oder "einfallslos" beschreiben können. Ist es doch nur ein relativ unscheinbarer Kunststoff-Block.

Wer von euch so einen Repeater braucht bzw. ihn einfach mal ausprobieren möchte, dem seit dieser Link empfohlen. *

* Wenn Ihr etwas über einen Partner-Link kauft, erhalte ich von Amazon ein paar Cent Provision für die Empfehlung. Für Euch ändert sich dadurch am Verkaufspreis nichts. (Amazon-Affiliate-Link des Amazon Partner Programm)

Kleine Info: Dieser Artikel wurde mit dem "zukünftigen" WordPress Editor "Gutenberg" verfasst, den ihr momentan zum Testen als WordPress-Plugin installieren und ausprobieren könnt.

Internet-Logbuch vom 22. Januar 2018

Webseiten-Umzug geschafft (uberspace > allinkl.com)

Vor einiger Zeit erreichte mich eine Mail von meinem Webhosting-Provider (uberspace), dass meine Server-Hardware von Meltdown bzw. Spectre betroffen wäre und nur der Umzug auf eine aktuellere Hardware-Plattform Abhilfe schaffen könnte.

Nun muss man wissen, dass auch der Umzug von einem uberspace zu einem andere nicht ganz einfach ist. Dafür gibt es (noch) keinen Automatismus und man muss ziemlich viel von Hand erledigen. 
Diesen Umstand nahm ich zum Anlass, dass ich einen Umzug dieser Webseite machen musste, aber dann habe ich auch gleich zu einen anderen Provider (allink.com) gewechselt. 

Was ich nicht überrissen hatte, war das der Domain-Umzug (KK-Antrag) bei meiner .net-Domain sehr lange dauern kann. Ich kennte der Prozedere bei .de-Domains und wenn man hier einen sogn. Auth-Code vom alten Provider besitzt, dann kann der Umzug solcher Domains in wenigen Stunden erfolgen.

Natürlich war dies bei meiner Domain anders und es wurde mir mitgeteilt, dass er Umzug bis zu 6 Tage dauern kann. Wollt ihr mal raten, wie lange der Umzug wirklich dann gedauert hat? Richtig 6 Tage. Darum war es auch in den vergangenen Tage hier relativ ruhig, da ich in dieser Zeit nicht wirklich sagen konnte, wann die Webseite beim neuen Provider dann aktiv ist. Mein Fehler war, dass ich gleich nach dem Stellen des KKs meine Webseiten inkl. mySQL Datenbank zum neuen Provider umgezogen habe, weil ich ja dachte, dass der Domainumzug schneller gehen würde.

Heute war es nun endlich soweit und die Domain ist nun beim neuen Provider angekommen. Jetzt dauert es vielleicht noch ein paar Tage bis wirklich alle DNS Server diese Änderung mitbekommen haben, aber ich denke das sollte kein Problem mehr darstellen. 

So, die ostermeier.net hat nun seid heute auch offiziell eine neue Heimat und findet sich nun auf den Servern von allinkl.com.

WordPress-Webseite funktioniert nach Umzug nicht mehr

Wie hier in meinem Blog schon erwähnt, ist heute diese Webseite nun auch offiziell bei einem neuen Provider gehostet. Dieses WordPress-Blog befindet sich nun auf den Server von allinkl.com.

Der eigentlich Umzug der Webseiten-Daten per FTP und Datenbank Export / Import verlief sehr problemlos. Heute ist mir aber dann, nach dem nun auch die Domain (endlich) umgezogen war, aber aufgefallen, dass zwar die WordPress-Startseite (die Seite mit den Artikeln) funktioniert, aber keine Unterseiten. Blöd.

Ich hab etwas gesucht und mir ist dann aufgefallen, dass es keine .htaccess Datei in meinem WordPress-Root-Verzeichnis gab. Bei meinem alten Provider (uberspace.de) war diese noch auf den Servern und ich konnte mir nicht wirklich erklären warum diese Datei beim FTP-Transfer nicht übertragen wurde. 
Meine Theorie hierzu ist: Ich habe mir meine Daten per FTP von meinem Mac aus mittels „Transmit“ geholt und auch auf diesem Weg zu allinkl.com übertragen. Ich denke mir mal, dass der Mac mit Dateien, die mit einem „.“ (Punkt) beginnen „ein Problem hat“, da diese ja standardmässig in der GUI von macOS nicht angezeigt werden und vielleicht konnte somit diese Datei auch nicht weiterübertragen werden.

Ich hab mir dann diese Datei geholt und sicher zu allinkl.com übertragen.
(Also erst per FTP auf den alten Server, dort umbenannt (also den Punkt entfernt), dann die Datei auf den Desktop des Macs übertragen und im Anschluss eine neue FTP Verbindung zum neuen Provider aufgebaut. Dann die Datei vom Desktop auf den Server übertragen und dort die Datei erneut umbenannt (Punkt wieder hinzugefügt.)
Und siehe da, ab diesem Zeitpunkt, als die Datei wieder vorhanden war, gingen auch alle meine Unterseiten. Jipiee. 🙂

Wegen der Vollständigkeit hier noch der Inhalt meiner .htaccess-Datei:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

Pick: Office 365 – Remover direkt von Microsoft

Hin und wieder installiere ich neue Rechner und bei einigen Herstellern ist „eine“ Testversion von Microsofts Office 365 vorinstalliert. Aber häufig kommt es auch vor, dass nicht nur die deutsche Version des Office-Pakets installiert ist, sondern (die Globalisierung lässt grüßen) viele Sprachvariation.
Bei mir und den PCs, die ich in der Hand hatte, kann es schon sein, dass bis zu 10 Version des Office in den „Programmen und Apps“ zu finden sind. Anfänglich habe ich noch jede einzelne Version von Hand deinstalliert, aber dies kann unter Umständen ca. 5-10 Minuten pro Version dauern und das war mir dann doch zu viel Zeitaufwand.

Also habe ich mich auf die Suche begeben, ob es nicht ein Removal-Tool für „alle“ Sprachversionen gibt. Und ich war dann doch etwas überrascht, als ich eben solch ein Tool direkt bei Microsoft gefunden habe.

Die dazu gehörige Webseite findet ihr unter: 

Nach der Auswahl des Betriebssystems und deinem Browser bekommt man eine Datei zum Download angeboten, die dann die Deinstallation vornimmt. (Die Datei hieß bei mir: o15-ctrremove.diagcab )

Nachfolgend eine kleine Bildstrecke, wie sich die Deinstallation bei mir gezeigt und verhalten hat.