Shapeoko 2: Warum funktionieren zwei Achsen nicht mehr?

Written by on . Posted in Allgemein, not_on_startpage

Ich bin gerade dabei, dass ich mir einen kleinen PC * für die Werkstatt zusammen baue, mit dem ich dann die Shapeoko steuern möchte. Da ich mit diesem PC in der Testphase bin, wollte ich auch die Steuerung über einen frisch gekauften Bluetooth-Stick ** testen. Die Installation des Sticks verlief erfreulich einfach, weil die Treiber dafür bereits in Windows 7 enthalten waren. Die Koppelung des Rechners und der Fräse verlief auch problemlos und als ich dann mal mit Easel die Shapeoko von Hand steuern wollte, bemerkte ist, dass eine Achse tadellos funktionierte, und die anderen beiden (X und Z) nur so ein „Anfahrgeräusch“ von sich gaben, aber keine wirklich Bewegung stattfand. Seltsam?!!?

Erst dachte ich, es läge vielleicht daran, da ich gerade erst den BT Stick installiert hatte, dass der PC vielleicht noch einen Reboot bräuchte um vielleicht die Treiber noch richtig zu initialisieren. Aber auch nach einem Reboot veränderte sich das Verhalten nicht.
Ich hab mich dann noch etwas mit dein Einstellungen der Fräse im „Easel“ beschäftigt und auch mit den „Erweiterten Einstellungen“ der Bluetooth-Schnittstelle – doch alles hat nichts geholfen.

Erst als ich einen weiteren Probelauf mit meinen Laptop machte (der bislang anstandslos funktioniert hat) und es mit dem das gleiche Verhalten aufwies, wusste ich, dass es nicht an den neuen PC lag, sondern das die Shapeoko irgendwo ein Problem hat.

Nach etwas Suchen bin ich dann schliesslich fündig geworden und der „Fehler“ war relativ einfach. Es war zwei Stecker auf dem Board locker geworden und hatten keinen richtigen Kontakt mehr. Daher wir die Fräse dann wohl erkannt haben, dass die Achse angesteuert wird, aber kein Signal bekommen hat, wie weit sie fahren soll.

Hier auf dem Foto sieht man recht schön, wie die 3 Kabel für die 3 Achsen auf das Board gehen. Und die beiden Kabel, die direkt unter dem Steppermotor enden, sind locker geworden. Und da ich normalerweise noch eine Abdeckung für dieses Board habe, fiel mir dies auch erst auf, als ich diese demontiert hatte.

Nachdem die Ursache nun gefunden war, war die Lösung auch denkbar einfach. Stecker wieder richtig draufstecken, testen und gut war. Ich frage mich jetzt nur, wie und warum diese Steckverbindungen überhaupt locker werden konnten. Denn eigentlich sie die Kabel gut fixiert und können sich garnicht soweit bewegen. Ich muss das nun mal noch beobachten und sollte das mit den lockeren Steckern noch öfter vorkommen, dann werd ich diese vielleicht mal mit einem Heißkleber-Punkt fixieren müssen.

* Sobald ich mal Zeit habe und der Rechner vorzeigbar ist, kann ich euch mal erläutern, welchen Hardware ich dafür verwendet habe. So viel sei schon erwähnt: Ich wollte eine relativ günstige Lösung und ich denke, dass ist mir nun auch gelungen. 

** Nachstehend noch schnell ein paar Tipps für euch, was ihr nehmen könntet, wenn ihr auch einen Bluetooth-Stick für euren PC braucht. ***

*** Wenn Ihr etwas über einen Partner-Link kauft, erhalte ich von Amazon ein paar Cent Provision für die Empfehlung. Für Euch ändert sich dadurch am Verkaufspreis nichts. (Amazon-Affiliate-Link des Amazon Partner Programm)

Tags: , , ,

Trackback from your site.

Markus Ostermeier

Contact: markus(at)ostermeier(dot)net - My Coffee is always #000000! - Base-Station: 48.749878 11.975666

Leave a comment