AHCI war schuld, dass Windows 7 beim Booten einen Fehlermeldung brachte

Written by on . Posted in Allgemein, Merkhilfen, Pick / Empfehlungen, Windows 10, Windows 7, Windows 8, Windows Vista

SATA-LogoVor ein paar Tagen hatte ich den Fall, dass ein Windows 7 Rechner beim booten eine Fehlermeldung (BlueScreen) brachte und ich erst einem davon ausging, dass die Windows-Installation beschädigt sei. Fehlercode war 0x0000007B oder so ähnlich.

Nach dem ich einiges an Reparaturversuchen ausprobiert hatte und alle keinen wirklichen Erfolg hatten, ist mir dann der Geistesblitz gekommen, dass so eine Fehlermeldung auch ein falsch eingestellter SATA-Modus verursachen könnte. Ich kannte das aus der Vergangenheit von Systemen, die ich neu installiert hatte und dort vergessen hatte, denn SATA-Modus umzustellen.

Bei AHCI werden die Steuerbefehle umsortiert, um sie in einer optimierten Reihenfolge zum Datenträger zu senden und so mehr Geschwindigkeit raus zu holen.

IMG_8694

Wer es genauer wissen möchte, dem empfehle ich folgenden Wiki-Artikel:

Dazu vielleicht noch ein paar interessante Auszüge aus dem Wikipedia-Artikel:

Ist die BIOS-Einstellung SATA Configuration bei Mainboards auf AHCI eingestellt, werden die angeschlossenen Festplatten mit Unterstützung von Native Command Queuing (NCQ) angesprochen. In Folge werden anstehende Befehle umsortiert, um sie in der optimalen Reihenfolge auszuführen. Meistens erhöht sich dadurch der Durchsatz der Festplatte um einige Prozent bei mehreren parallel arbeitenden Programmen mit vielen verstreuten Zugriffen.

und weiter …

Bei Microsoft Windows VistaWindows 7 sowie Windows 8 und Windows 8.1 (*) muss, falls das System im IDE-Modus installiert wurde, dazu erst ein Schlüssel in der Windows Registry geändert werden,[1] da sonst ein Blue Screen auftritt.

ide_to_ahci_windows7_01
Seltsam war bei meinem Fall eigentlich nur, warum sich das SATA-Modus bei einem PC „einfach so verstellt“ haben sollte? Die Bios-Batterie war nicht leer. Der PC lief am Vortag noch tadellos und ich kann mir auch nicht vorstellen, dass irgendwer in den BIOS Einstellungen herum gepfuscht haben sollte. Somit hatte ich den falschen SATA-Modus auch garnicht auf dem Radar und bin erst relativ spät auf diesen Lösungsansatz gekommen.

Aber vielleicht hilft euch ja dieser Tipp und ihr habt dafür mal eine Verwendung. 😉

* Anmerkung des Autors:
Ich gehe mal davon aus, dass auch Windows 10 den AHCI-Modus für SATA-Geräte voraussetzt.

 

Tags: , , ,

Trackback from your site.

Markus Ostermeier

Contact: markus(at)ostermeier(dot)net - My Coffee is always #000000! - Base-Station: 48.749878 11.975666

Leave a comment