Mac-Problem: reboot after hibernate

Written by on . Posted in Allgemeines, Technik

Seit einigen Wochen, genauer vielleicht 3 Monaten, hab ich bei meinem MBP das Problem, dass sich der Laptop neu startet, wenn er aus dem „Tiefschlaf“ erwachen soll. Genauer gesagt, wenn das Notebook im Akkubetrieb ist, dann der Strom ausgeht und das System ein Abbild des Speichers auf die Festplatte (in meinem Fall eine SSD) schreibt (/var/vm/sleepimage) und ich anschliessend das Netzteil wieder anschliesse und den Einschalt-Knopf drücke, dann macht der Mac einen Reboot.
Auffällig ist vielleicht, dass ich dieses Phänomen ungefähr seit dem Zeitpunkt habe, seitdem ich von 4 auf 8GB den Speicher aufgerüstet habe. Ich hatte darum als erstes den RAM Speicher in Verdacht, aber nachdem wir diesen schon 3x ausgetauscht haben, kann ich eigentlich defekten RAM ausschliessen. Da ich sehr guten Kontakt zum Apple-Händler habe, haben wir auch schon das Logic-Board getauscht, jedoch ebenfalls ohne nennenswerte Verbesserung. Auch die (Neu)Installation von Mac OS X10.6 behob das Problem nicht. Auch nicht nach SMC Reset bzw. Preset-Reset (Starten mit gedrückter ALT+CMD+R+P Tasten).
Den einzigen „hilfreichen bzw. konkreten“ Hinweis hab ich im „system.log“ (via Konsole) gefunden. Dort steht, wenn der Mac nach dem Aufwachen einen Neustart macht: configd[15]: Sleep: Platform Failure – AC 2
Wenn man danach googled bekommt man einige Ergebnisse und man bekommt den Eindruck, dass das Problem mehr Leute haben. Auch scheint diese Phänomen nicht auf die Laptop-Sparte beschränkt zu sein, denn ich habe auch gelesen, dass mac mini´s, iMac´s und sogar Mac Pro´s davon betroffen sind.
Vielleicht hat ja jemand einen Lösungsansatz bzw. hatte das gleiche Problem und hat es in den Griff bekommen.

Nachtrag 31. März 2011:
Bin an dem Thema dran geblieben und hab mal in diversen Foren meine Lage geschildert und im BitundSo-Forum hab ich einen wertvollen Tipp erhalten. Dort wurde mir mitgeteilt, dass das Problem durch meine verbaute OCZ Vertex 2 SSD verursacht werden könnte und dass eine Firmware-Update dies beheben könnte. Daraufhin hab ich auf den Webseiten von OCZ nachgeschaut und siehe da, das letzte bzw. aktuelle Firmware-Update für meinen SSD-Modell war vom 24. März 2011. 😉
Ich hab bislang das Update noch nicht gemacht, da die mit einigen Vorbereitungen und Stolpersteinen verbunden ist, dies werd ich dann zu passender Zeit in einem separaten Post beschreiben. Ich halte euch aber auf dem Laufenden ..

Nachtrag 1. April 2011 – kein Aprilscherz:
Heute nun hab ich das Firmware-Updater der SSD gemacht und dass Ganze lief reibungsloser, als ich mir eigentlich gedacht hatte. Von dem her kann ich jedem nur die Angst vor einem Firmware-Update bei OCZ SSD nehmen 😉 Ich bin zwar bei der SSD jetzt auf dem Software-Stand 1.32 (vom 24. März 2011), vorher war´s ver. 1.28, aber leider wurde dadurch mein „Aufwach- bzw. Reboot-Problem“ immer noch nicht gelöst. Auch mein Versuch mit den Originalen 4GB brachte keine Besserung, so dass ich nun die 8GB RAM wieder verbaut habe.

Nachtrag 11. Mai 2011:
Habe soeben (nach dem ich beim letzten Mal festgestellt habe, dass SSD Firmware-Updates nicht schlimm sind) von der Version 1.32 auf die 1.33 bei meiner OCZ SSD Vertrex2 upgedatet. Das Update lief problemlos. Zu meiner reboot/hibernate-Problem kann ich noch nichts sagen, da der Akku grad voll ist. 😉
Nachtrag 12. Mai 2011: Leider, Leider. Ich hab über Nacht den Akku fast leer werden lassen und hab heute morgen dann (kontrolliert) den Mac in den Tiefschlaf geschickt, doch leider hat das SSD Firmware Update nicht verändert. Wenn ich den Mac aus dem Tiefschlaf wecke, dann kommt kurz der graue Bildschirm (bei dem eigentlich der Fortschrittsbalken erscheinen sollte, der anzeigt, wie weit der Zurückschreiben des RAM Inhaltes ist), dieser verschwindet nach einer Sekunde und der Mac Bootet wieder neu.

Nachtrag – 30. Juni 2011:
Hatte heute Gelegenheit, dass ich eine andere SSD ausprobieren konnte. Es war keine OCZ. Aber auch nach dem ich mein System geklont , die andere SSD verbaut hatte und mein Mac OS X wieder normal lief, rebootete mein MacBook Pro nachdem ihm der Sanf ausgegangen war neu. Schade eigentlich. 🙁

Tags: , , , , ,

Trackback from your site.

Comments (7)

  • SirAnn

    |

    wie genau hast du das Firmware-Update durchgeführt? Direkt unter Os X? Wenn ja, hast du da nen Anleitungslink?

    Reply

    • markus

      |

      Hallo,
      nee, habs auch nicht unter Mac OS zusammen gekriegt.
      Hab mir dann dafür entschieden, dass ich der Firmware-Update mittels BootCamp und Windows 7 durchführe. Allerdings muss, damit es funktioniert, auf der SSD eine NTFS Partition vorhanden sein.
      Dann gibts problemlos. 😉
      Servus Markus

      Reply

  • stefan

    |

    Hallo, der letzte Eintrag hier ist ja einen Moment her, trotzdem hänge ich mich mal dran.

    Ich habe das Problem auch, sehr nervig. Konnte noch nicht genau die Umstände reproduzieren, es ist immer eine Zitterpartie ob nach dem Wieder-Aufwecken eine Meldung kommt daß ich neu starten soll. Bei mir erfolgt eine Aufforderung, den Powerknopf lange gedrückt zu halten.

    Ich habe an meinem MBP (late 2009) 3 Änderungen zeitgleich vorgenommen, sodaß ich den Fehler nicht sicher auf eine einzelne zurückführen kann.
    1) Upgrade des RAM von 4 auf 8 GB
    2) Upgrade der Festplatte von 320 auf 750 GB
    3) Upgrade von Snow Leopard auf Lion

    Interessant ist, daß ich keine SSD habe. Und die Festplatte habe ich zwischendurch nochmal getauscht, da ich mit der erste 750GB (WesternDigital) nicht zufrieden war, hat aber keinen Unterschied gemacht. Hatte eher den RAM im Verdacht, entweder defekte Bausteine oder aber Hibernate funktioniert mit der Menge des RAM nicht.

    Hat sich Dein Problem mittlerweile gelöst, oder gibt es neue Erkenntnisse?

    Reply

    • admin

      |

      Hallo,

      nee, bei mir hat sich das Problem noch nicht gelöst. Hab aber dann irgendwann aufgegeben nachzuforschen.
      Das Speicherupgrade von 4 auf 8 GB hab ich auch gemacht. Das wäre schon mal eine Übereinstimmung.
      Ich hab eine zusätzliche SSD eingebaut…hmm, weis nicht, ob das damit zusammen hängt.
      Das Problem hatte ich auch schon unter Snow Leopard und hat sich mit ins Lion rüber geschleppt. Hatte da die Hoffnung, dass sich das Problem mit einem Major-Update vielleicht von selbst beheben würde.

      Ich für meinen Teil habe eigentlich auch eher den RAM in Verdacht, aber ich habe verschiedene Speicherriegel ausprobiert, an denen liegt es scheinbar nicht. Eigentlich dürfen auch die Menge des RAMs kein Problem sein, da wir in der Arbeit mehrere Rechner mit 8 GB haben und bei den funktioniert es auch. Vielleicht ist das ein spezielles Problem von den MBP aus 2009 ?

      Servus Markus

      Reply

  • iMactouch

    |

    Hallo!

    Das ist ja endlich einmal genau das, was ich auch habe. 🙁
    Ich habe einen iMac (24″ 2007, 6GB RAM, 1,5TB Platte), den ich bisher immer erfolgreich mit dem Hibernatemode 3 benutzt habe. Er wachte immer problemlos auf.
    Vor kurzem habe ich in ein externes Firewire 800 Gehäuse eine SSD eingebaut und dort Lion installiert. Immer wenn dort der Hibernatemode aktiviert wird, startet er immer komplett neu, genau wie es hier beschrieben wird. Mit der internen Platte gibt es das Problem nach wie vor nicht. 🙁
    Eine Lösung habe ich bisher leider nicht gefunden.

    Schönen Tag!
    Carsten

    Reply

  • iMactouch

    |

    Hallo!

    Das ist ja endlich einmal genau das, was ich auch habe. 🙁
    Ich habe einen iMac (24″ 2007, 6GB RAM, 1,5TB Platte), den ich bisher immer erfolgreich mit dem Hibernatemode 3 benutzt habe. Er wachte immer problemlos auf.
    Vor kurzem habe ich in ein externes Firewire 800 Gehäuse eine SSD eingebaut und dort Lion installiert. Immer wenn dort der Hibernatemode aktiviert wird, startet er immer komplett neu, genau wie es hier beschrieben wird. Mit der internen Platte gibt es das Problem nach wie vor nicht. 🙁
    Eine Lösung habe ich bisher leider nicht gefunden.

    Schönen Tag!
    Carsten

    Reply

Leave a comment